Back to overview
Downtime
Degraded Call Quality
Apr 10, 2026 at 8:48pm UTC
Affected services
Telephony
Resolved
Apr 10, 2026 at 9:04pm UTC
All services and quality have been restored and back to normal. We will continue to monitor the situation.
Affected services
Updated
Apr 10, 2026 at 9:02pm UTC
We are currently experiencing a temporary service interruption following a system restart.
Affected services
Created
Apr 10, 2026 at 8:48pm UTC
Our team has identified a temporary decrease in call audio quality. We are actively monitoring the situation and working to restore normal performance as quickly as possible.
Affected services